Bug #86203

Avoid excluding fields in copyToLanguage

Added by Oliver Hader 2 months ago. Updated 20 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
DataHandler aka TCEmain
Target version:
-
Start date:
2018-09-09
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Given that a TCA column is using 'l10n_mode' => 'exclude' and creating a "free localization" of that record using DataHandler's copyToLanguage command, the according field stays empty in the created localization.

$GLOBALS['TCA']['tt_content']['columns']['header']['l10n_mode'] = 'exclude';

The expected behavior would have been, that the accordings field is still duplicated once on creating the duplicate for a particular language.

Associated revisions

Revision f1f194a4 (diff)
Added by Oliver Hader 20 days ago

[BUGFIX] Avoid excluding fields in copyToLanguage

Given that a TCA column is using 'l10n_mode' => 'exclude' and creating
a "free localization" of that record using DataHandler's copyToLanguage
command, the according field stays empty in the created localization.

The expected behavior is that the accordings field is still duplicated
once on creating the duplicate for a particular language. Title prefix
"[Translate to <language>:]" is expected to be missing here since it
is the result of a copy command instead of a localize command.

Resolves: #86203
Releases: master
Change-Id: Ib9914a8d02cbbabdbdc56720a983b6314a34709b
Reviewed-on: https://review.typo3.org/58235
Tested-by: TYPO3com <>
Reviewed-by: J├╝rgen Heym <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Benni Mack <>
Tested-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58235

#2 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58235

#3 Updated by Gerrit Code Review 21 days ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58235

#4 Updated by Gerrit Code Review 21 days ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58235

#5 Updated by Oliver Hader 20 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF