Bug #86383

adminpanel ConfigurationService calls getTSConfig in a deprecated way

Added by Benjamin Franzke 12 months ago. Updated 12 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
AdminPanel
Target version:
-
Start date:
2018-09-26
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Since https://review.typo3.org/56968 handing over arguments to getTSConfig() is deprecated.
That means the following code logs a deprecation warning:

$this->mainConfiguration = $this->getBackendUser()->getTSConfig('admPanel')['properties'];

Associated revisions

Revision 7f8f518d (diff)
Added by Benjamin Franzke 12 months ago

[BUGFIX] adminpanel: Do not use getTSConfig in a deprecated way

Since https://review.typo3.org/56968 handing over arguments
to getTSConfig() is deprecated.

As a drive-by we also fix some related wrong getTSConfig() mocks
in Unit/Middleware/AdminPanelInitiatorTest.php – they do not
produce errors, but these mocks are too unspecific, as they
still allow an argument to be passed.

Releases: master
Resolves: #86383
Related: #85016
Change-Id: I7254b5d0b87bc66da319728f7fe82aaa614b6a43
Reviewed-on: https://review.typo3.org/58396
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Reviewed-by: Markus Klein <>
Tested-by: Markus Klein <>
Reviewed-by: Wouter Wolters <>
Reviewed-by: Georg Ringer <>
Tested-by: Georg Ringer <>

History

#1 Updated by Gerrit Code Review 12 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58396

#2 Updated by Benjamin Franzke 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack 12 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF