Bug #86386

Run silent upgraders after install tool login

Added by Christian Kuhn about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-09-26
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Related issues

Related to TYPO3 Core - Bug #86155: Login in Backend after Upgrading from 8.7.19 to 9.4 throws error Closed2018-09-05

Actions
#1

Updated by Gerrit Code Review about 3 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58398

#2

Updated by Christian Kuhn about 3 years ago

  • Status changed from Under Review to New

This is an edge case especially during upgrading:

  • upgrade core from v8 to v9
  • load typo3/install.php
  • touch typo3conf/ENABLE_INSTALL_TOOL
  • reload typo3/install.php
  • login

-> the silent upgraders are not executed. If then setting a new install tool password or adding a be user, those will always be argon password hashes even if that hash mechanism is not available, because the password hash config has not been properly written to LocalConfiguration.php yet.

Solution: Do not call mainLayout() on successful standalone login, but execute silent upgrade wizards before.

#3

Updated by Christian Kuhn about 3 years ago

  • Related to Bug #86155: Login in Backend after Upgrading from 8.7.19 to 9.4 throws error added
#4

Updated by Christian Kuhn about 3 years ago

  • Status changed from New to Under Review
#5

Updated by Christian Kuhn about 3 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF