Bug #86563

Exception is thrown in view module if root page is selected

Added by Oliver Bartsch about 2 years ago. Updated over 1 year ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2018-10-03
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Current behaviour:
  • If clicking the root page (id=0) in the view module and there is no Page with is_siteroot Field set, an ServiceUnavailableException is thrown with the Message: No pages are found on the rootlevel!
  • Furthermore, in the case that a Page with is_siteroot Field set exists under the root page (id=0), the view module displays this Page while actually the root page was selected. This is very confusing.
Steps to reproduce:
  • Set up clean TYPO3 9.5 installation (or set all pages deleted=1)
  • Click in the view module and select the root page (id=0) in the page tree
Would expect:
  • See an information not an Exception
  • See the selected page not a other page only because it's marked as siteroot


Files

view-module_exception.png (280 KB) view-module_exception.png Oliver Bartsch, 2018-10-03 21:43
#1

Updated by Gerrit Code Review about 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58573

#2

Updated by Gerrit Code Review about 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58573

#3

Updated by Gerrit Code Review about 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58573

#4

Updated by Gerrit Code Review about 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58573

#5

Updated by Gerrit Code Review about 2 years ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58573

#6

Updated by Oliver Bartsch about 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#7

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF