Bug #86631

Page tree tooltips should contain shortcut and mountpoint details

Added by Tymoteusz Motylewski 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Should have
Category:
Pagetree
Target version:
-
Start date:
2018-10-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

For some page in v8 I have a toltip:
"id=161856 - Mount Point of Feedback (id=18) - Mount Point redirects to mounted page"

in v9:

"id=161856 - Mount Point of Feedback (id=18)"

and for shortcuts:

is:
id=29 - Shortcut to page (id=0)

should be:
id=29 - Shortcut to page (id=0), Shortcut Mode First subpage of selected/current page

The issue is that some fields are not selected in the pageTreeRepository, so BackendUtility::titleAttribForPages is missing them.

Associated revisions

Revision 2a42940d (diff)
Added by Tymoteusz Motylewski 2 months ago

[BUGFIX] Correct tooltips for pages in the page tree

Make tooltips for pages in the page tree correct (in case of shortcuts,
and mountpoints).

  • add missing fields to selection in page tree Repository
    required by BackendUtility->titleAttribForPages()
  • add guard clauses for page 0 to avoid unnecessary processing
  • fixes several notices

Resolves: #86631
Releases: master
Change-Id: Ia0229203b78ef8c58e066ef3a587c1de1ee0b975
Reviewed-on: https://review.typo3.org/58616
Tested-by: TYPO3com <>
Reviewed-by: Susanne Moog <>
Tested-by: Susanne Moog <>
Reviewed-by: Stefan Neufeind <>
Tested-by: Stefan Neufeind <>

History

#1 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58616

#2 Updated by Tymoteusz Motylewski 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF