Bug #86773

Include enable columns as default in BackendUtility getRootline

Added by Joerg Kummer 10 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-10-27
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

After patch for #86512, which includes field 'hidden' as default for rootline data, we thought about to implement further enable columns.

Default for TCA pages are:
  • hidden
  • starttime
  • endtime
  • fe_group
Currently BackendUtility gets root line with following fields per default:
  • uid
  • pid
  • title
  • doktype
  • slug
  • tsconfig_includes
  • TSconfig
  • is_siteroot
  • t3ver_oid
  • t3ver_wsid
  • t3ver_state
  • t3ver_stage
  • backend_layout_next_level
  • hidden

Adding fields 'starttime', 'endtime', and 'fe_group' would at least render correct page with status icons in backend modul for site configuration, which currently do not respect these three fields. You can reproduce it this way:

Given

Three sites, in web root which all are set to 'is_siteroot'.
Each site must have one of these three fields 'starttime', 'endtime', and 'fe_group' filled, that changes it icon at least in pagetree.

Expected

All views which lists pages with icons, should render page icons including the status. Also backend modul for site configuration.

Actual

Backend modul for site configuration shows only icon with correct doktype, labeled with 'hidden' overlay if disabled or not.
Scheduled, endtime restricted or frontend user group restricted pages got not the expected icon overlay, as seen i fx pagetree.

Furthermore, following fields will also change icon overlay, and got not rendered correctly too. But they are not in the group of enable columns:
  • nav_hide
  • content_from_pid
  • module
  • extendToSubpages

To fix this, these fields must just added to already given lists in EXT:backend/Classes/Utility/BackendUtility.php in static methods BEgetRootLine() and getPageForRootline().


Related issues

Related to TYPO3 Core - Bug #87076: Missing icon overlays within usage of BackendRootline Closed 2018-12-04

History

#1 Updated by Joerg Kummer 10 months ago

  • Complexity set to easy

#2 Updated by Joerg Kummer 10 months ago

  • Description updated (diff)

#3 Updated by Joerg Kummer 8 months ago

  • Related to Bug #87076: Missing icon overlays within usage of BackendRootline added

#4 Updated by Joerg Kummer 8 months ago

This is duplicate of #87076, solved and can be closed.

#5 Updated by Bjoern Jacob 8 months ago

  • Status changed from New to Closed

Closed as requested by author. Thanks mate!

Also available in: Atom PDF