Bug #86864

SuggestWizard within FlexForms does not work

Added by Stefan Froemken over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend JavaScript
Target version:
Start date:
2018-11-06
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
easy
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

I have a TCA group field in my Plugin-FlexForm with activated suggest feature. But when I try to find a record, autosuggest keeps empty.

Browser console return Error 500:
#1478345642 RuntimeException
Identifier could not be decoded to an array.

You have converted many backend JavaScript into a compressed version. And here is the problem.

In TYPO3 8.7 FormEngineSuggest.js:

dataStructureIdentifier = $searchField.data('datastructureidentifier'),

In TYPO3 9.5.1 FormEngineSuggest.js:

dataStructureIdentifier = e.dataset.datastructureidentifier

It looks like the same, but in TYPO3 8.7 the jquery data() function will convert string into JSON, if it looks like JSON:

if ( rbrace.test( data ) ) {
    return JSON.parse( data );
}

This conversion will not happen, if you try to access data attributes with dataset directly.

Stefan

#1

Updated by Gerrit Code Review over 2 years ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58855

#2

Updated by Gerrit Code Review over 2 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58855

#3

Updated by Gerrit Code Review over 2 years ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58855

#4

Updated by Gerrit Code Review over 2 years ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/58855

#5

Updated by Stefan Froemken over 2 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#6

Updated by Benni Mack almost 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF