Feature #86937

Missing feature to update all sub-pages URL-Segment or the some section in the tree of pages

Added by Vasyl Mosiychuk almost 3 years ago. Updated almost 3 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2018-11-15
Due date:
% Done:

0%

Estimated time:
PHP Version:
7.2
Tags:
TYPO3 9.5.x
Complexity:
hard
Sprint Focus:

Description

Situation:

  1. I did fresh install TYPO3 9.5.x
  2. I move some pages from one section to other section
  3. When I move pages, I in fact changing URL segment
  4. After moved pages need to change the field `slug` with name `URL Segment`
  5. This feature missing

At least you could use a workaround if no one comes up with a better approach. TYPO3 provides a multi edit feature for single fields. You can switch to list view, select the parent page. Then you should see all child pages within list view. If you click on the single table, you should be able to expand only pages, hiding all further record types. In the bottom a select should appear, where you can select the `slug` field. Next in the bottom you should be able to switch to 2nd clipboard which has multi selection. Select all records and click on the edit button of the `slug` field in table column.

This is one way... Is good if We have few pages but if we have many pages... this is bad and difficult and inconvenient.

We need feature for quickly update field `slug`as few pages and for many pages.


Related issues

Related to TYPO3 Core - Feature #86496: When changing an url-segment / a parent-slug allow to update slug of subpagesClosed2018-10-01

Actions
Related to TYPO3 Core - Feature #87341: Automatic "URL Segment" update and redirect after moving page or changing slug informationClosed2019-01-07

Actions
Related to TYPO3 Core - Feature #86495: When changing a slug allow to auto-create redirects from old URLsClosed2018-10-01

Actions
#1

Updated by Georg Ringer almost 3 years ago

  • Category changed from Pagetree to Link Handling, Site Handling & Routing
#2

Updated by Georg Ringer almost 3 years ago

  • Related to Feature #86496: When changing an url-segment / a parent-slug allow to update slug of subpages added
#3

Updated by Georg Ringer almost 3 years ago

  • Status changed from New to Closed

thanks for reporting the issue. Closing it as duplicate of #86496

#5

Updated by Vasyl Mosiychuk almost 3 years ago

  • Related to Feature #87341: Automatic "URL Segment" update and redirect after moving page or changing slug information added
#6

Updated by Georg Ringer over 2 years ago

  • Related to Feature #86495: When changing a slug allow to auto-create redirects from old URLs added

Also available in: Atom PDF