Bug #87003

Plugins overrides Page Data

Added by Daniel Kary about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
Category:
Fluid Styled Content
Target version:
-
Start date:
2018-11-26
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
fluid template data
Complexity:
Is Regression:
Sprint Focus:

Description

Problem:
If you want to get the Page Layout or Title of the active Page with <f:debug>{data.layout}</f:debug> it works just if there are no Plugins like Forms, Powermail oder own Moduls on this Page. If there is a Plugin, in <f:debug>{data}</f:debug> are now the Values of the Plugin, not the Page.
This means as soon as there is an Plugin in the Page, i don't have access at the data from this page in fluid.

How to get the Problem:
  1. Use in your Fluid-Template {data.title} or {data.layout} on a site with something regular like Text & Media.
  2. It Works
  3. Now insert a Forms-, Powermail-, or Own-Plugin in this Site
  4. Now you get nothing or the values from the Plugin if they are filled.

Related issues

Is duplicate of TYPO3 Core - Bug #86979: stdWrap fieldRequired/insertData sometimes not working as expected since TYPO3 9 LTSClosed2018-11-22

Actions
#1

Updated by Georg Ringer about 2 years ago

closed as duplicate of #76489

#2

Updated by Georg Ringer about 2 years ago

  • Is duplicate of Bug #76489: f:cObject resets other global parameters in fluid_styled_content added
#3

Updated by Georg Ringer about 2 years ago

  • Status changed from New to Closed
#4

Updated by Helmut Hummel almost 2 years ago

  • Is duplicate of deleted (Bug #76489: f:cObject resets other global parameters in fluid_styled_content)
#5

Updated by Helmut Hummel almost 2 years ago

  • Is duplicate of Bug #86979: stdWrap fieldRequired/insertData sometimes not working as expected since TYPO3 9 LTS added

Also available in: Atom PDF