Project

General

Profile

Actions

Bug #87014

closed

Link when l18n_cfg is set to "Hide default translation of page" isn't generated

Added by Sebastian Schawohl about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-11-27
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When a page has the field l18n_cfg set to "Hide default translation of page" the link is empty <a href="">Page title</a> in menus, and no link is generated with …\Link\PageViewHelper.

The page in default language is hidden, and shown when translated, this part works.

When debugging the array for the menu, the key link for the page with l18n_cfg=1 is empty.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #86363: Broken navigation link when using "Hide default translation of page"Closed2018-09-24

Actions
Actions #1

Updated by Sebastian Klein about 5 years ago

  • Is duplicate of Bug #86363: Broken navigation link when using "Hide default translation of page" added
Actions #2

Updated by Benni Mack almost 5 years ago

  • Status changed from New to Needs Feedback

Hi Sebastian,

we've worked on this in v9.5.5 - can you please check if your issue is fixed with the latest version?

thanks.
Benni.

Actions #3

Updated by Sebastian Schawohl almost 5 years ago

Hi Benni,

I've checked and it's working as expected now with v9.5.5.

Thank you

Actions #4

Updated by Riccardo De Contardi almost 5 years ago

  • Status changed from Needs Feedback to Closed

@Sebastian Kurfuerst Schawohl thank you for your answer and sorry for this late reply; I close this issue for now as it is resolved.

If you think that this is the wrong decision or experience the issue again please reopen it or ping me. Thank you and best regards.

Actions

Also available in: Atom PDF