Bug #87025

sysext:seo: XML sitemap shouldn't display subpages of a restricted page

Added by Dima Nozdrin about 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2018-11-28
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Pages that are restricted for fe_users are not displayed in the XML sitemap.
But when the checkbox extendToSubpages is checked all subpages are displayed in the XML sitemap.


Related issues

Related to TYPO3 Core - Bug #16561: Typolink doesn't check if a page in rootline has some access and include subpages is set...Accepted2006-09-13

Actions
Related to TYPO3 Core - Bug #19297: extendToSubpages not workingClosedChristian Kuhn2008-09-07

Actions
#1

Updated by Dima Nozdrin about 2 years ago

The issue goes back to the

\TYPO3\CMS\Frontend\ContentObject\ContentObjectRenderer::typoLink()

that builds urls with the use of

\TYPO3\CMS\Frontend\Typolink\PageLinkBuilder::resolvePage()

that uses

\TYPO3\CMS\Frontend\Page\PageRepository::getPage()

that doesn't respect 'extendToSubpages' and 'fe_group' values of parent pages.
Either getPage() method should be fixed or restricted pages should be filtered in

\TYPO3\CMS\Seo\XmlSitemap\PagesXmlSitemapDataProvider

that seems to be more preferable

#2

Updated by Dima Nozdrin about 2 years ago

  • Related to Bug #16561: Typolink doesn't check if a page in rootline has some access and include subpages is set... added
#3

Updated by Dima Nozdrin about 2 years ago

  • Related to Bug #19297: extendToSubpages not working added
#4

Updated by Richard Haeser almost 2 years ago

  • Status changed from New to Closed

Also available in: Atom PDF