Bug #87271

Replace @ignorevalidation in SearchController

Added by Alexander Schnitzler 9 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Category:
-
Start date:
2018-12-22
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Related issues

Related to TYPO3 Core - Task #86901: Drop evaluation of @ignorevalidation annotations Closed 2018-12-24 2018-12-24

Associated revisions

Revision 0777264e (diff)
Added by Alexander Schnitzler 9 months ago

[BUGFIX] Replace @ignorevalidation in SearchController

@ignorevalidation is still used in the SearchController
which causes deprecation log notices.

While https://review.typo3.org/58886/ fixed this bug in TYPO3 10,
this patch aims to do the same for 9.5. It's a dedicated patch
with a seperate ticket number due to the fact, that the patch for
TYPO3 10 missed the backport notice.

Releases: 9.5
Resolves: #87271
Change-Id: I7bc538a3fc3d45d2483bc88dedb3fcf125f2f76c
Reviewed-on: https://review.typo3.org/59275
Reviewed-by: Christian Kuhn <>
Tested-by: Christian Kuhn <>
Tested-by: TYPO3com <>
Reviewed-by: Anja Leichsenring <>
Tested-by: Anja Leichsenring <>

History

#1 Updated by Alexander Schnitzler 9 months ago

  • Related to Task #86901: Drop evaluation of @ignorevalidation annotations added

#2 Updated by Gerrit Code Review 9 months ago

  • Status changed from New to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/59275

#3 Updated by Anonymous 9 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF