Bug #87408

UriBuilder->convertDomainObjectsToIdentityArrays doesn'thandle AbstractDomainObject correclty

Added by Ivano Luberti 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-01-11
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

TYPO3 version 9.5.3

In UriBuilder->convertDomainObjectsToIdentityArray

there is the following code

if ($argumentValue instanceof \TYPO3\CMS\Extbase\DomainObject\AbstractDomainObject) {
if ($argumentValue->getUid() !== null) {
$arguments[$argumentKey] = $argumentValue->getUid();
.....

as result using actionlink arguments produce a link with the id object instead of the object itself.
Undesired side effect is that is not possible in Extbase to use actions with domain object as parameter pointed by actionLinks


Related issues

Duplicates TYPO3 Core - Bug #87409: UriBuilder->convertDomainObjectsToIdentityArrays doesn'thandle AbstractDomainObject correclty New 2019-01-11

History

#1 Updated by Ivano Luberti 6 months ago

Sorry you close this, I have reported it on the wrong project

Ivano Luberti wrote:

TYPO3 version 9.5.3

In UriBuilder->convertDomainObjectsToIdentityArray

there is the following code

if ($argumentValue instanceof \TYPO3\CMS\Extbase\DomainObject\AbstractDomainObject) {
if ($argumentValue->getUid() !== null) {
$arguments[$argumentKey] = $argumentValue->getUid();
.....

as result using actionlink arguments produce a link with the id object instead of the object itself.
Undesired side effect is that is not possible in Extbase to use actions with domain object as parameter pointed by actionLinks

#2 Updated by Michael Stucki 6 months ago

  • Project changed from forge.typo3.org to TYPO3 Core
  • TYPO3 Version set to 9

Wrong project.

#3 Updated by Georg Ringer 6 months ago

  • Status changed from New to Closed

closed as duplicate of #87409

#4 Updated by Georg Ringer 6 months ago

  • Duplicates Bug #87409: UriBuilder->convertDomainObjectsToIdentityArrays doesn'thandle AbstractDomainObject correclty added

Also available in: Atom PDF