Project

General

Profile

Actions

Bug #87656

closed

Slugs error if title has "/" in extbase extension

Added by Martin Weymayer about 5 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-02-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If you have a title in an extension like "Mein Titel hat / Slash / im Titel" TYPO3 occures error


(1/1) Symfony\Component\Routing\Exception\InvalidParameterException

Parameter "tx_xxx_xxx__frage" for route "tx_xxx_xxx_0" must match "[^/]++" ("mein-titel-hat-/-slash-/-im-titel" given) to generate a corresponding URL.

Here is my TCA for slug

'path_segment' => [
            'exclude' => true,
            'label' => 'URL Segment',
            'config' => [
                'type' => 'slug',
                'prependSlash' => true,
                'generatorOptions' => [
                    'fields' => ['frage'],
                    'prefixParentPageSlug' => false,
                ],
                'fallbackCharacter' => '-',
                'eval' => 'uniqueInSite',
            ],
        ],

So "/" in url should be deleted automatically


Related issues 2 (0 open2 closed)

Related to TYPO3 Core - Bug #88291: Exception thrown if slash in route field of PersistedPatternMapper aspectClosed2019-05-07

Actions
Is duplicate of TYPO3 Core - Bug #86740: Using slash in slug in extension record throws exception in frontendClosed2018-10-25

Actions
Actions

Also available in: Atom PDF