Bug #87657

Moving content elements via Drag'n'Drop to uppermost position attempts to move record to root-level (pid 0) when "Languages" layout is selected in backend

Added by Oliver joppnet 6 months ago. Updated 27 days ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-02-05
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
drag'n'drop
Complexity:
Is Regression:
Sprint Focus:

Description

Howdy,

we've come across a weird issue when moving content elements with drag'n'drop in the TYPO3 backend.

It's quite hard to explain so I've attached a short video.

In short, TYPO3 seems to attempt moving content elements to the root-level (pid 0) when moving the content element to the first position. Moving a CE from the first position to the second does work fine.

Worth noting here is that this behaviour does only apply when you're in the "Languages" layout. All is working fine in the "Columns" layout, so it seems to be a client side script issue (?). Moving a CE to the first position in "List" view via arrow sorting buttons does work fine as well, which corroborates our assumption that this might be a client-side issue (JS) in the TYPO3 backend.

Funny enough, if you change the page title (on which the content elements to drag'n'drop are located) to start with an integer (e.g. "50 days of summer") it doesn't try to move the CE to root-level (pid 0) but to the pid 50 (depending on what number the page title starts with).

Can anyone confirm this issue?

[TYPO3 CMS 9.5.4] - Google Chrome 2019-02-05 13-01-52.mp4 - Screencast of what happens (or doesn't). (4.59 MB) Oliver joppnet, 2019-02-05 13:15

History

#1 Updated by Riccardo De Contardi 29 days ago

  • Status changed from New to Needs Feedback

I am not able to reproduce this issue on 9.5.7 or 10.0.0-dev; is it solved? if not, could you add a step-by-step guide about how to reproduce it? Thank you!

#2 Updated by Oliver joppnet 28 days ago

Riccardo De Contardi wrote:

I am not able to reproduce this issue on 9.5.7 or 10.0.0-dev; is it solved? if not, could you add a step-by-step guide about how to reproduce it? Thank you!

Can't reproduce in TYPO3 9.5.7 either. Seems fixed.

Thank you!

#3 Updated by Riccardo De Contardi 28 days ago

  • Status changed from Needs Feedback to Closed

@Oliver joppnet thank you for your kind and quick reply; I close this issue for now as resolved;

If you think that this is the wrong decision or experience the issue again, please reopen it or ping me.

Thank you again.

#4 Updated by Paul Albrecht 27 days ago

Oliver joppnet wrote:

Howdy,

we've come across a weird issue when moving content elements with drag'n'drop in the TYPO3 backend.

It's quite hard to explain so I've attached a short video.

In short, TYPO3 seems to attempt moving content elements to the root-level (pid 0) when moving the content element to the first position. Moving a CE from the first position to the second does work fine.

Worth noting here is that this behaviour does only apply when you're in the "Languages" layout. All is working fine in the "Columns" layout, so it seems to be a client side script issue (?). Moving a CE to the first position in "List" view via arrow sorting buttons does work fine as well, which corroborates our assumption that this might be a client-side issue (JS) in the TYPO3 backend.

Funny enough, if you change the page title (on which the content elements to drag'n'drop are located) to start with an integer (e.g. "50 days of summer") it doesn't try to move the CE to root-level (pid 0) but to the pid 50 (depending on what number the page title starts with).

Can anyone confirm this issue?

Confirmed on Typo3 9.5.7

#5 Updated by Oliver joppnet 27 days ago

Paul Albrecht wrote:

Confirmed on Typo3 9.5.7

I tested it on the same installation the other day like in the video I posted several months ago with the ticket and couldn't reproduce the issue. Hmmm.

#6 Updated by Riccardo De Contardi 27 days ago

I've just had a brief conversation with Paul Albrecht; as far as I have understood (He can correct me if I am wrong), it seems that the issue is present when working with EXT:gridelements, i.e.when the drag and drop is performed inside an EXT:gridelement structure.

Can someone confirm?

#7 Updated by Oliver joppnet 27 days ago

Riccardo De Contardi wrote:

I've just had a brief conversation with Paul Albrecht; as far as I have understood (He can correct me if I am wrong), it seems that the issue is present when working with EXT:gridelements, i.e.when the drag and drop is performed inside an EXT:gridelement structure.

Can someone confirm?

Cannot confirm this. I do have gridelements 9.2.2 installed, but neither having the issues outside nor inside of an EXT:gridelement structure. The video I posted with the ticket serveral months ago (https://forge.typo3.org/attachments/download/34105/%5BTYPO3%20CMS%209.5.4%5D%20-%20Google%20Chrome%202019-02-05%2013-01-52.mp4) shows no gridelements structures were involved when I first had the issue. Cannot reproduce the issue anymore though. :/

@Paul Albrecht Do you happen to have the issue in an updated TYPO3 installation (e.g. updated from TYPO3 6.x to 9.x recently)?

Also available in: Atom PDF