Bug #87771

Non-breaking space rendered after ul/ol in contenttable cell

Added by Patrick no-lastname-given 5 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
RTE (rtehtmlarea + ckeditor)
Target version:
Start date:
2019-02-22
Due date:
% Done:

100%

TYPO3 Version:
8
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If a ul or ol is inserted in a table cell in ckeditor, a non-breaking-space is rendered after the ul/ol in the frontend.

Associated revisions

Revision a7d1189c (diff)
Added by Patrick Lenk 2 months ago

[BUGFIX] Remove non-breaking-space after list element in contenttable

The   for HTMLtableCells in parseFunc_RTE has been removed.
Empty cells still contain the non-breaking space.

Resolves: #87771
Releases: master
Change-Id: Ic95a215f07597954cebffc7aff73dd15dcce986b
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784
Tested-by: TYPO3com <>
Tested-by: Guido Schmechel <>
Tested-by: Tobi Kretschmann <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Guido Schmechel <>
Reviewed-by: Steffen Frese <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Tobi Kretschmann <>

History

#1 Updated by Riccardo De Contardi 5 months ago

Is this the same issue? #83795

#2 Updated by Patrick no-lastname-given 5 months ago

Riccardo De Contardi wrote:

Is this the same issue? #83795

Not 100%. And the revert of #83795 is correct.

In this issue the &nbsp is only rendered after the list, if the list is in a contenttable. And i have a different bugfix, but currently problems with pushing to gerrit (i hope the core moves to github soon).

To fix this, i would remove the ifBlank = &nbsp for HTMLtableCells in parseFunc_RTE:

lib.parseFunc_RTE{  
    externalBlocks{
        table{
            HTMLtableCells{
                default.stdWrap {
                    parseFunc.nonTypoTagStdWrap.encapsLines.innerStdWrap_all.ifBlank = 
                }
            }
        }
    }
}

#3 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#4 Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#5 Updated by Gerrit Code Review 5 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#6 Updated by Riccardo De Contardi 5 months ago

I could possibly be totally wrong, but... putting an &nbsp; in the table cell seem something that Internet Explorer required in the ol' days because it was not able to put a border on empty cells

#7 Updated by Patrick no-lastname-given 5 months ago

Riccardo De Contardi wrote:

I could possibly be totally wrong, but... putting an &nbsp; in the table cell seem something that Internet Explorer required in the ol' days because it was not able to put a border on empty cells

A empty cell still has a non-breaking space with this bugfix.

#8 Updated by Gerrit Code Review 4 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#9 Updated by Gerrit Code Review 4 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#10 Updated by Gerrit Code Review 4 months ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#11 Updated by Gerrit Code Review 4 months ago

Patch set 7 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#12 Updated by Gerrit Code Review 4 months ago

Patch set 8 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/59784

#13 Updated by Anonymous 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#14 Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF