Feature #87822

og:title and og:description should take title and description values if they are not set

Added by Jérémie Roulin 6 months ago. Updated 6 months ago.

Status:
Rejected
Priority:
Could have
Assignee:
-
Category:
SEO
Target version:
-
Start date:
2019-03-02
Due date:
% Done:

0%

Estimated time:
1.00 h
PHP Version:
Tags:
Complexity:
easy
Sprint Focus:

Description

In the new SEO extension, if the og_title or og_description field is not set those fields are not rendered in the page. IMHO, it should take the value of seo_title and description automatically.

History

#1 Updated by Georg Ringer 6 months ago

  • Status changed from New to Needs Feedback

IMO it doesn't make any sense to render that twice. Facebook & co take the <title> tag as fallback anyway. so why should the same content be rendered as title and as og-title tag?

#3 Updated by Richard Haeser 6 months ago

  • Tracker changed from Bug to Feature
  • Priority changed from Must have to Could have
  • Target version deleted (next-patchlevel)

Having a fallback to the page title and description doesn't make sense. Social networks fall back to these tags themselves if needed. But I would really advice to think about your social title and description. Social networks have other max lengths and also have a slightly different purpose than search results. In search you would like to attract people that are searching for a specific topic. On social media, you would like to standout between all other normal posts.

See https://www.richardhaeser.com/ and https://developers.facebook.com/tools/debug/sharing/?q=https%3A%2F%2Fwww.richardhaeser.com

I know there is also the question of having "default" titles and descriptions, but that doesn't make sense either. Why should every page have the same title / description. It wouldn't standout to all the other pages.

If you have prove otherwise, please let me know!

BTW: It is definitely not a bug, if needed it is more a missing feature.

#4 Updated by Georg Ringer 6 months ago

  • Status changed from Needs Feedback to Rejected

I am closing this issue.

#5 Updated by Jérémie Roulin 6 months ago

For me it's a real missing feature. Issue should not closed like this. Please consider also this post : https://webmasters.stackexchange.com/questions/121343/same-ogtitle-and-title-on-a-page.
Thanks

Also available in: Atom PDF