Bug #87981

404 Page when Google Analytics Parameters (utm_source) in URL

Added by Patrick Bloch 10 months ago. Updated 9 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2019-03-22
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

When I try to invoke a URL with utm_source, utm_medium and utm_campaign parameters, I get a 404 error.

on the product detail page i get a 404 error: www.mydomain.com/products/my-product?utm_source=Test&utm_medium=email&utm_campaign=Test

on an normal page without the ProductPlugin it works: www.mydomain.com/service?utm_source=Test&utm_medium=email&utm_campaign=Test

In the cacheHash excludedParameters tis params are already included

Here is my site config:

routeEnhancers:
  ProductPlugin:
    type: Extbase
    limitToPages:
      - 17
    extension: MyExt
    plugin: Product
    routes:
      -
        routePath: '/{product_title}'
        _controller: 'Product::show'
        _arguments:
          product_title: product
    defaultController: 'Product::list'
    aspects:
      product_title:
        type: PersistedAliasMapper
        tableName: tx_myext_domain_model_product
        routeFieldName: slug


Related issues

Related to TYPO3 Core - Bug #87845: cacheHash.excludedParameters will be ignore when Enhancer is called Closed 2019-03-05

History

#1 Updated by Grigory Rechkin 10 months ago

  • Related to Bug #87845: cacheHash.excludedParameters will be ignore when Enhancer is called added

#2 Updated by Georg Ringer 10 months ago

  • Status changed from New to Needs Feedback

thanks for creating the issue. can you check if the patch of #87845 work for you or if the issue is even a duplicate? thanks!1

#3 Updated by Patrick Bloch 10 months ago

the patch works for me. thanks for the fast respond.

#4 Updated by Riccardo De Contardi 10 months ago

  • Category set to Link Handling, Site Handling & Routing

#5 Updated by Georg Ringer 9 months ago

  • Status changed from Needs Feedback to Closed

closed as duplicate

Also available in: Atom PDF