Bug #88026

Invalid URLs for JavaScript files in system extension install

Added by Dirk Wenzel about 2 months ago. Updated about 2 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2019-03-27
Due date:
% Done:

0%

TYPO3 Version:
7
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Yes
Sprint Focus:

Description

The JS files of the system extension install are located in Resources/Public/Javascript/.

The partial Resources/Private/Partials/Action/Common/Headers.html refers to Resources/Public/JavaScript

<meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=no">
<meta http-equiv="content-type" content="text/html; charset=UTF-8" />
<link rel="stylesheet" type="text/css" href="../Resources/Public/Css/InstallTool.css?{time}" />
<link rel="icon" type="image/vnd.microsoft.icon" href="../Resources/Public/Icons/favicon.ico?{time}" />
<script type="text/javascript" src="../../core/Resources/Public/JavaScript/Contrib/jquery/jquery-2.1.4.min.js?{time}"></script>
<script type="text/javascript" src="../../backend/Resources/Public/JavaScript/jquery.clearable.js?{time}"></script>
<script type="text/javascript" src="../Resources/Public/JavaScript/bootstrap.min.js?{time}"></script>
<script type="text/javascript" src="../Resources/Public/JavaScript/Install.js?{time}"></script>

On case sensitive servers the resources are not found. Install Tool and Backen are broken.

This error occurred after updating to ELTS 7.6.35 (from 7.6.32)
*Note: resource paths for core and backend extensions are correct

History

#1 Updated by Anja Leichsenring about 2 months ago

  • Status changed from New to Closed

Hi Dirk,

I just checked the source code for 7.6.32 (the last version released as LTS), please see for yourself, that the folder is named JavaScript, the same casing as it is called upon in the partial you recite: https://git.typo3.org/Packages/TYPO3.CMS.git/tree/refs/heads/TYPO3_7-6:/typo3/sysext/install/Resources/Public

The same casing is in the ELTS 7.6 repository, I just checked that, too.

So I conclude that your issue is not caused by the version you got from ELTS, but that some modification took place on your side. Can you check that somehow?

As a side note: please report ELTS issues on the ELTS service desk, you find the link on the confluence page for the credentials you received. This bugtracker here is not actively monitored by the ELTS team. I close this issue here, if you find the ELTS version the cause of your issue please report it again to the ELTS Service Desk.

#2 Updated by Dirk Wenzel about 2 months ago

Hi Anja,
thanks for your quick reply.

I observed the issue on two independent instances. Both were built via composer.

So there is little to no chance of modification.
I will investigate it further and report on the ELTS service desk if necessary.

cheers
Dirk

Also available in: Atom PDF