Bug #88061

Forms: jQuery UI datepicker / Comment causes "Uncaught SyntaxError: Unexpected end of input"

Added by Benedikt Imminger about 2 months ago. Updated 22 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Form Framework
Target version:
-
Start date:
2019-04-03
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

  1. Add datepicker to form
  2. Activate "Enable datepicker (needs jQuery UI)"
  3. Go to frontend: console says "Uncaught SyntaxError: Unexpected end of input"

See attached screenshot.

I think this error is caused by sysext/form/Classes/ViewHelpers/Form/DatePickerViewHelper.php:

//By using "backspace" or "delete", you can clear the datepicker again …

Tested with Forms 9.5.5

Inspector.png View (193 KB) Benedikt Imminger, 2019-04-03 15:16

History

#1 Updated by Bjoern Jacob about 2 months ago

  • Sprint Focus set to Remote Sprint

#2 Updated by Susanne Moog about 1 month ago

  • Status changed from New to Needs Feedback

Do you have any additional compressing / minifying via extension (especially one using minifyJavaScript)? Any special settings? I cannot reproduce this with a basic TYPO3 installation - however from the code and your screenshot something is failing to minify the JS comment correctly so I'm guessing you are using an additional extension for that.

#3 Updated by Bjoern Jacob 23 days ago

  • Sprint Focus deleted (Remote Sprint)

#4 Updated by Benedikt Imminger 22 days ago

The problem was caused by tinysource/min. I changed the settings of the extension and the issue disappeared.

Sorry, for posting a bug report which was not caused by TYPO3.

#5 Updated by Bjoern Jacob 22 days ago

  • Status changed from Needs Feedback to Closed
  • % Done changed from 0 to 100

Thank you for your feedback. Great that you've solved your problem. Closing this issue :)

Also available in: Atom PDF