Bug #88066

Install - wrong value returned in function executeDatabaseSelectAction

Added by Riccardo De Contardi 3 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Install Tool
Target version:
-
Start date:
2019-04-03
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

According to the reporting by Robin Scholz on Slack, on typo3/sysext/install/Classes/Controller/InstallerController.php the wrong "true" value is returned at the lines 572-581 (latest master) https://github.com/TYPO3/TYPO3.CMS/blob/28a25f4f39a186fdcaaea0e01f9d91aacb4881a2/typo3/sysext/install/Classes/Controller/InstallerController.php#L572-L581:

        } else {
            return new JsonResponse([
                'sucess' => true,
                'status' => [
                    new FlashMessage(
                        'You must select a database.',
                        'No Database selected',
                        FlashMessage::ERROR
                    ),
                ],
            ]);
        }

Also, sucess is spelled wrong.

Thanks Robin for your findings!

Btw the issue is present also on 9.5.5, but at different lines (568-577)

Associated revisions

Revision a776d58d (diff)
Added by Guido Schmechel 2 months ago

[BUGFIX] Ensure correct value for JsonResponse in InstallerController

Set the correct status value for the JsonResponse returned in case no
database is selected.
Additionally, a typo in the key `success` itself is fixed.

Resolves: #88066
Releases: master, 9.5
Change-Id: I3153f6cabc878b270fe48983cbdedb8ed918d566
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60466
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Frank Naegler <>
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Tested-by: Frank Naegler <>

Revision 497e1a8c (diff)
Added by Guido Schmechel 2 months ago

[BUGFIX] Ensure correct value for JsonResponse in InstallerController

Set the correct status value for the JsonResponse returned in case no
database is selected.
Additionally, a typo in the key `success` itself is fixed.

Resolves: #88066
Releases: master, 9.5
Change-Id: I3153f6cabc878b270fe48983cbdedb8ed918d566
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60729
Tested-by: TYPO3com <>
Tested-by: Frank Naegler <>
Reviewed-by: Frank Naegler <>

History

#1 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60466

#2 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60466

#3 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60729

#4 Updated by Guido Schmechel 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack 2 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF