Project

General

Profile

Actions

Bug #88084

closed

Respect mod.web_list.hideTranslations again

Added by Jan Helke almost 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Language Manager (backend)
Target version:
Start date:
2019-04-05
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
easy
Is Regression:
Yes
Sprint Focus:

Description

With resolving issue #82991 the localization list view is always used when translations are present in the system. But now for all entries it is checked, what translations are present and all translations will be show in the list. This behaviour renders the PageTsconfig option mod.web_list.hideTranslations useless.

It should be still possible to hide translations e.g. on overview pages for translators where they know that translations are present but only need a fast list of all default language entries.

I consider that as a regression, because documented behaviour is not working: https://docs.typo3.org/typo3cms/TSconfigReference/PageTsconfig/Mod.html#web-list

Actions #1

Updated by Gerrit Code Review almost 5 years ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60372

Actions #2

Updated by Gerrit Code Review almost 5 years ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60372

Actions #3

Updated by Gerrit Code Review almost 5 years ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60413

Actions #4

Updated by Jan Helke almost 5 years ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
Actions #5

Updated by Benni Mack almost 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF