Bug #88100

Page tree hooks removed in TYPO3 v9 without deprecation warning in TYPO3 v8

Added by Patrick Broens 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Pagetree
Target version:
-
Start date:
2019-04-06
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In TYPO3 v9 the page tree data provider has been removed. This data provider was containing very useful hooks for manipulating the page tree, like
  • Changing the sorting of parts of the page tree (like on date), using node post processing
  • Adding suffix or prefix to the page title in the page tree (like a date), using node post processing
  • Filtering pages
  • Getting tree mounts

The hooks could be used with

$GLOBALS['TYPO3_CONF_VARS']['SC_OPTIONS']['t3lib/tree/pagetree/class.t3lib_tree_pagetree_dataprovider.php']['postProcessCollections']

According to the TYPO3 core team rules no hooks can be suddenly removed without a proper deprecation warning in the previous version, in this case TYPO3 version 8. There were no deprecation warnings in version 8

History

#1 Updated by Patrick Broens 5 months ago

  • Category set to Pagetree

#2 Updated by Georg Ringer 5 months ago

  • Status changed from New to Needs Feedback

the removal of the mentioned hook has been anounced as breaking change with issue #82426

see https://docs.typo3.org/typo3cms/extensions/core/Changelog/9.0/Breaking-82426-ExtJSAndExtDirectRemoval.html for the related documentation.

breaking changes sometimes need to happen and as you know it is tried to have those as less as possible. I would propose to create a new issue to propose additional hooks, is that ok?

#3 Updated by Patrick Broens 5 months ago

The removal of the hooks was done with no regard to the TYPO3 core development policy, which clearly states: TYPO3 core development policy states that public API will not be changed without a grace period where extension authors can adapt to the changes. In that grace period a deprecation warning will be thrown. If you want to remove or change functionality in the TYPO3 core, it has to be deprecated first.

See https://docs.typo3.org/typo3cms/ContributionWorkflowGuide/Appendix/HowToDeprecateThings.html

Since they are hooks, they are part of the public API of TYPO3.

The new classes for the page tree are declared @internal, which means they are not part of the public API. This means it makes no sense to add a hook or signal to it. @internal means no information should be displayed in public documentation.

Nevertheless, I will have a look if I can propose new signals or hooks

#4 Updated by Georg Ringer 5 months ago

  • Status changed from Needs Feedback to Closed

besides breaking changes ...

as you created #88099 anyway, I will close this issue

Also available in: Atom PDF