Bug #88149

Missing vendor in Fluid Ajax Widgets

Added by Stefan Froemken 2 months ago. Updated about 2 months ago.

Status:
Under Review
Priority:
Must have
Assignee:
-
Category:
Fluid
Start date:
2019-04-15
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hello Core-Team,

I'm just playing around with Ajax based Fluid Widgets. When I create an URI with f:widget.uri the URI was builded correctly, but if you visit the Link, you will get following error message:

Invalid configuration: "vendorName" is not set

Please have a look into WidgetContext.php. You will see that there is no method for vendor. So vendor was not stored into session and is not available while executing the AjaxCall.

Stefan

History

#1 Updated by Gerrit Code Review 2 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60475

#2 Updated by Gerrit Code Review 2 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60477

#3 Updated by Gerrit Code Review 2 months ago

Patch set 2 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60477

#4 Updated by Benni Mack about 2 months ago

  • Target version changed from next-patchlevel to Candidate for patchlevel

Also available in: Atom PDF