Bug #88248

page translations are hidden by default

Added by Benni Mack 7 months ago. Updated 7 months ago.

Status:
Closed
Priority:
Should have
Assignee:
Category:
Localization
Target version:
Start date:
2019-04-30
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

In TYPO3 v8, new pages_language_overlay records were not hidden by default, but due to the merge into pages, new page translations are always hidden.


Related issues

Related to TYPO3 Core - Bug #89622: TCA ctrl setting hideAtCopy not considered for pages during localization New 2019-11-08

Associated revisions

Revision 5a3ee8c3 (diff)
Added by Benni Mack 7 months ago

[BUGFIX] Unhide page translations by default

In TYPO3 v8, new page translations within pages_language_overlay
were visible by default when using plain DataHandler.

In TYPO3 v9, due to the merge into "pages" for translations,
the default value for "hidden" is used. Every new page translation
is now hidden by default - this is a different behavior.

Tests had to be modified to make this work again. However,
the change now removes the "hacks" within the tests,
and adds the functionality to take-over the "hidden" flag
from the default record.

For future TYPO3 major versions, the hidden field could be migrated
into a "allowLanguageSynchronization" once the Context API
is used throughout Core properly.

Resolves: #88248
Releases: master, 9.5
Change-Id: I2a684a0d4225451c3fbfc0021c09935c1224aaca
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60632
Tested-by: TYPO3com <>
Tested-by: Andreas Fernandez <>
Tested-by: Richard Haeser <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Mathias Brodala <>
Reviewed-by: Richard Haeser <>

Revision 06c6c1eb (diff)
Added by Benni Mack 7 months ago

[BUGFIX] Unhide page translations by default

In TYPO3 v8, new page translations within pages_language_overlay
were visible by default when using plain DataHandler.

In TYPO3 v9, due to the merge into "pages" for translations,
the default value for "hidden" is used. Every new page translation
is now hidden by default - this is a different behavior.

Tests had to be modified to make this work again. However,
the change now removes the "hacks" within the tests,
and adds the functionality to take-over the "hidden" flag
from the default record.

For future TYPO3 major versions, the hidden field could be migrated
into a "allowLanguageSynchronization" once the Context API
is used throughout Core properly.

Resolves: #88248
Releases: master, 9.5
Change-Id: I2a684a0d4225451c3fbfc0021c09935c1224aaca
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/60636
Tested-by: TYPO3com <>
Tested-by: Richard Haeser <>
Reviewed-by: Richard Haeser <>

History

#1 Updated by Gerrit Code Review 7 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60632

#2 Updated by Gerrit Code Review 7 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60632

#3 Updated by Gerrit Code Review 7 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/60636

#4 Updated by Benni Mack 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#5 Updated by Benni Mack 7 months ago

  • Status changed from Resolved to Closed

#6 Updated by Oliver Hader 29 days ago

  • Related to Bug #89622: TCA ctrl setting hideAtCopy not considered for pages during localization added

Also available in: Atom PDF