Bug #88316

Do not set type attribute by default in script tag for page.includeJS (HTML5 compliance)

Added by Sybille Peters 4 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2019-05-09
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
no-brainer
Is Regression:
Sprint Focus:

Description

https://docs.typo3.org/typo3cms/TyposcriptReference/latest/Setup/Page/#includejs-array

A script element with type="text/javascript" is generated by default. This is unnecessary and w3c validator generates warnings.


Related issues

Related to TYPO3 Core - Bug #45512: Make the type attribute optional on script, style and link elements Accepted 2013-02-15

History

#1 Updated by Riccardo De Contardi 4 months ago

  • Related to Bug #45512: Make the type attribute optional on script, style and link elements added

#2 Updated by Riccardo De Contardi 4 months ago

Duplicate of #45512 , I guess.

#3 Updated by Sybille Peters 4 months ago

  • Status changed from New to Closed

Ok, I am closing.

Also available in: Atom PDF