Bug #88576

SiteProcessorTest produces a warning because of wrong method mocking for getSiteFinder()

Added by Benjamin Franzke 12 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-06-17
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description


1) TYPO3\CMS\Frontend\Tests\Unit\DataProcessing\SiteProcessorTest::nullIsProvidedIfSiteCouldNotBeRetrieved
Trying to configure method "getSiteFinder" which cannot be configured because it does not exist, has not been specified, is final, or is static

Associated revisions

Revision c4dd8ff8 (diff)
Added by Benjamin Franzke 12 months ago

[BUGFIX] Fix getSiteFinder() mocking in SiteProcessorTest

As it produced a warning:
1) TYPO3\CMS\Frontend\Tests\Unit\DataProcessing\SiteProcessorTest::
nullIsProvidedIfSiteCouldNotBeRetrieved
Trying to configure method "getSiteFinder" which cannot be configured
because it does not exist, has not been specified, is final, or is static

Resolves: #88576
Related: #88568
Releases: master
Change-Id: Icf72100282ce24c87b6bb9f49fc978b6187a817e
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61074
Tested-by: Benni Mack <>
Tested-by: TYPO3com <>
Tested-by: Benjamin Franzke <>
Reviewed-by: Benni Mack <>
Reviewed-by: Benjamin Franzke <>

History

#1 Updated by Gerrit Code Review 12 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61074

#2 Updated by Benjamin Franzke 12 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#3 Updated by Benni Mack 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF