Bug #88598

SubModule must implement ContentProviderInterface otherwise exception will be thrown

Added by Jan Stockfisch 5 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Should have
Category:
AdminPanel
Target version:
-
Start date:
2019-06-20
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
CodingNight
Complexity:
easy
Is Regression:
Sprint Focus:

Description

All SubModules must implement the TYPO3\CMS\Adminpanel\ModuleApi\ContentProviderInterface or an InvalidArgumentException is thrown. Therefore AbstractSubModule should implement this Interface by default.

Associated revisions

Revision a841cb87 (diff)
Added by Jan Stockfisch about 1 month ago

[BUGFIX] AbstractSubModule implements ContentProviderInterface by default

Because all submodules must implement the interface anyway, it's now
implemented by default in the AbstractSubModule. Without implementing
an InvalidArgumentException is thrown.

Resolves: #88598
Releases: master,9.5
Change-Id: I72f764a5fca63d85fb501ddcecc27bfc849b63bb
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61102
Tested-by: TYPO3com <>
Tested-by: Steffen Frese <>
Tested-by: Frank Nägler <>
Reviewed-by: Steffen Frese <>
Reviewed-by: Frank Nägler <>

Revision 015520cd (diff)
Added by Jan Stockfisch about 1 month ago

[BUGFIX] AbstractSubModule implements ContentProviderInterface by default

Because all submodules must implement the interface anyway, it's now
implemented by default in the AbstractSubModule. Without implementing
an InvalidArgumentException is thrown.

Resolves: #88598
Releases: master,9.5
Change-Id: I72f764a5fca63d85fb501ddcecc27bfc849b63bb
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61901
Tested-by: TYPO3com <>
Tested-by: Frank Nägler <>
Reviewed-by: Frank Nägler <>

History

#1 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61102

#2 Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61102

#3 Updated by Gerrit Code Review 4 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61102

#4 Updated by Susanne Moog 3 months ago

  • Tags set to CodingNight

#5 Updated by Gerrit Code Review 3 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61102

#6 Updated by Gerrit Code Review 3 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61102

#7 Updated by Gerrit Code Review about 1 month ago

Patch set 6 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61102

#8 Updated by Gerrit Code Review about 1 month ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61901

#9 Updated by Jan Stockfisch about 1 month ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF