Bug #88700

search in page tree and shortened page titles fails

Added by Henri Nathanson 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Should have
Category:
Backend User Interface
Target version:
-
Start date:
2019-07-08
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
pagetree,CodingNight
Complexity:
Is Regression:
Sprint Focus:

Description

pre notice: took me some time to find the new issue button

Longer page titles are shortened in the page tree. The search actually uses this data and will not find pages, where the parts searched for are cut off.

Associated revisions

Revision c8fbb178 (diff)
Added by Michael Blunck 3 months ago

[BUGFIX] Removes cropping from pagetree title

Pagetree uses javascript for search.
Cropping causes issues because not the full title
is searched. As the pagetree is neither scrollable
nor resizable, cropping does not make sense anyway
and is therefor removed.

Resolves: #88700
Releases: master, 9.5
Change-Id: I23bd7d1b46a7c455effa0d0452fb6bbeef8ab8eb
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61417
Reviewed-by: Susanne Moog <>
Reviewed-by: Thomas Anders <>
Reviewed-by: Jörg Bösche <>
Reviewed-by: Georg Ringer <>
Tested-by: Thomas Anders <>
Tested-by: TYPO3com <>
Tested-by: Jörg Bösche <>
Tested-by: Georg Ringer <>

Revision ef3b0f29 (diff)
Added by Michael Blunck 2 months ago

[BUGFIX] Removes cropping from pagetree title

Pagetree uses javascript for search.
Cropping causes issues because not the full title
is searched. As the pagetree is neither scrollable
nor resizable, cropping does not make sense anyway
and is therefor removed.

Resolves: #88700
Releases: master, 9.5
Change-Id: I23bd7d1b46a7c455effa0d0452fb6bbeef8ab8eb
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61365
Tested-by: TYPO3com <>
Tested-by: Frank Naegler <>
Tested-by: Andreas Fernandez <>
Reviewed-by: Frank Naegler <>
Reviewed-by: Andreas Fernandez <>

History

#1 Updated by Daniel Windloff 3 months ago

Can be reproduced in current master.

This also affects the renaming the page in the page tree.

TYPO3\CMS\Backend\Controller\Page\TreeController->pagesToFlatArray the visible text is cropped (GeneralUtility::fixed_lgd_cs). The visible text is also used for search and renaming.

#2 Updated by Susanne Moog 3 months ago

  • Tags changed from pagetree to pagetree,CodingNight

#3 Updated by Susanne Moog 3 months ago

  • Assignee set to Michael Blunck

#4 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61417

#5 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61365

#6 Updated by Michael Blunck 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF