Bug #88729

Link wizard doesn't update hidden field value

Added by Andreas Fernandez 12 days ago. Updated about 17 hours ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-07-11
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Yes
Sprint Focus:

Description

Using the link wizard in FormEngine doesn't update its hidden field that is submitted to the server, which results in broken states.


Related issues

Related to TYPO3 Core - Task #88665: Move "Refresh required" popup into FormEngine.js Closed 2019-07-01

Associated revisions

Revision 11bfd648 (diff)
Added by Andreas Fernandez 12 days ago

[BUGFIX] Re-add fieldChangeFunc for input fields

With #88665 some JavaScript code and superfluous event "registration" was
removed. It turns out that the event stuff was not that superfluous and is
still required with the Link Browser to properly update the field values.

Resolves: #88729
Related: #88665
Releases: master
Change-Id: I78a5e65f42a978245e31d478b83d82949c26ac17
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61272
Tested-by: Benni Mack <>
Tested-by: TYPO3com <>
Tested-by: Frank Naegler <>
Reviewed-by: Benni Mack <>
Reviewed-by: Markus Klein <>
Reviewed-by: Frank Naegler <>

History

#1 Updated by Andreas Fernandez 12 days ago

  • Related to Task #88665: Move "Refresh required" popup into FormEngine.js added

#2 Updated by Gerrit Code Review 12 days ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61272

#3 Updated by Andreas Fernandez 12 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack about 17 hours ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF