Bug #88935

Module menu jumps around when viewport is built

Added by Andreas Fernandez 2 months ago. Updated 2 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
Start date:
2019-08-08
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Use case:
Either the module menu is collapsed or module groups are collapsed

Current behavior:
When the viewport is built, both the module groups and the module menu are expanded. The settings get fetched via AJAX and adjust the module menu afterward.

Wanted behavior:
The menu state should be correct on rendering already, avoiding any jumpings and "laggy" UI.

Associated revisions

Revision c1915fab (diff)
Added by Andreas Fernandez 2 months ago

[BUGFIX] Set module menu state on render time

The module menu now contains its state whether either the menu itself, or
its module groups are expanded or collapsed. This information is now taken
into account when the markup of the backend viewport is rendered.

With this patch, some AJAX requests done after the backend is initialized
can bre dropped, improving the backend UX since the state of the menus is
correctly handled on render time.

Resolves: #88935
Releases: master, 9.5
Change-Id: I3f3765926d9d3f406af0ee0bc29993d547771853
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61477
Tested-by: TYPO3com <>
Tested-by: Frank Naegler <>
Tested-by: Richard Haeser <>
Reviewed-by: Frank Naegler <>
Reviewed-by: Richard Haeser <>

Revision b42530d2 (diff)
Added by Andreas Fernandez 2 months ago

[BUGFIX] Set module menu state on render time

The module menu now contains its state whether either the menu itself, or
its module groups are expanded or collapsed. This information is now taken
into account when the markup of the backend viewport is rendered.

With this patch, some AJAX requests done after the backend is initialized
can bre dropped, improving the backend UX since the state of the menus is
correctly handled on render time.

Resolves: #88935
Releases: master, 9.5
Change-Id: I3f3765926d9d3f406af0ee0bc29993d547771853
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61477
Tested-by: TYPO3com <noreply@typo3.com>
Tested-by: Frank Naegler <frank.naegler@typo3.org>
Tested-by: Richard Haeser <richard@maxserv.com>
Reviewed-by: Frank Naegler <frank.naegler@typo3.org>
Reviewed-by: Richard Haeser <richard@maxserv.com>
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61513

History

#1 Updated by Gerrit Code Review 2 months ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61477

#2 Updated by Andreas Fernandez 2 months ago

  • Target version set to next-patchlevel
  • TYPO3 Version changed from 10 to 9

#3 Updated by Andreas Fernandez 2 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Gerrit Code Review 2 months ago

  • Status changed from Resolved to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61513

#5 Updated by Andreas Fernandez 2 months ago

  • Status changed from Under Review to Resolved

Also available in: Atom PDF