Bug #88997

Error: Cannot use object of type stdClass as array

Added by Kurt Gusbeth 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-08-22
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

After Updating from TYPO3 9.5.8 to 9.5.9 I get this error:

(1/1) Error

Cannot use object of type stdClass as array
in /_TYPO3-Sourcen/typo3_src-9.5.9/typo3/sysext/backend/Classes/Controller/BackendController.php line 254

        // Prepare the scaffolding, at this point extension may still add javascript and css
        $view = $this->getFluidTemplateObject($this->templatePath . 'Backend/Main.html');

        $collapseState = $this->getBackendUser()->uc['BackendComponents']['States']['typo3-module-menu']['collapsed'] ?? false;
        $view->assign('moduleMenuCollapsed', $collapseState === true || $collapseState === 'true');
        $view->assign('moduleMenu', $this->generateModuleMenu());
        $view->assign('topbar', $this->renderTopbar());

"Flush TYPO3 and PHP Cache" and "rm -r typo3temp" didnĀ“t helped.
I see this error in 2/4 projects.
What could be the problem?


Related issues

Related to TYPO3 Core - Bug #89105: Update 9.5.8 to 9.5.9 - Cannot use object of type stdClass as array (Backend) Closed 2019-09-07
Duplicates TYPO3 Core - Bug #88984: Exception in BackendController 'Cannot use object of type stdClass as array' on $collapseState ( line 254 ) Closed 2019-08-20

History

#1 Updated by Guido Schmechel 6 months ago

  • Duplicates Bug #88984: Exception in BackendController 'Cannot use object of type stdClass as array' on $collapseState ( line 254 ) added

#2 Updated by Guido Schmechel 6 months ago

Please test the patch from https://review.typo3.org/c/Packages/TYPO3.CMS/+/61519 and add some feedback :-)

#3 Updated by Riccardo De Contardi 6 months ago

  • Status changed from New to Closed

I close this issue as a duplicate of #88984 that already has a pacth attached; please continue the discussion there.

I've added there the description of this issue to keep track of it.

Thank you.

#4 Updated by Lars Gremme 5 months ago

  • Related to Bug #89105: Update 9.5.8 to 9.5.9 - Cannot use object of type stdClass as array (Backend) added

Also available in: Atom PDF