Bug #89081

PHP Warning in Backend Module Indexing -> List: Pages

Added by Devid Messner 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Indexed Search
Target version:
-
Start date:
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

The backend module produces a PHP error

PHP Warning: json_decode() expects parameter 1 to be string, array given in /web/typo3/sysext/indexed_search/Classes/Domain/Repository/AdministrationRepository.php line 363

Related issues

Related to TYPO3 Core - Bug #88493: Exception in Indexed Search Administration Modul Resolved 2019-06-05
Follows TYPO3 Core - Bug #86994: indexed_search doesn't index pages using route enhancers Closed 2018-11-25

Associated revisions

Revision 2308f9ac (diff)
Added by Devid Messner 3 months ago

[BUGFIX] Remove double json_decode call

Avoids an exeption about incompatible type to the call, caused by double encoding.

Resolves: #89081
Releases: master, 9.5

Change-Id: Ia974227f0e9ca68a8f37a0e205bda1f27f015c7f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61622
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Tested-by: Frank Nägler <>
Reviewed-by: Anja Leichsenring <>
Reviewed-by: Frank Nägler <>

Revision d489a1aa (diff)
Added by Devid Messner 3 months ago

[BUGFIX] Remove double json_decode call

Avoids an exeption about incompatible type to the call, caused by double encoding.

Resolves: #89081
Releases: master, 9.5
Change-Id: Ia974227f0e9ca68a8f37a0e205bda1f27f015c7f
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61744
Tested-by: TYPO3com <>
Tested-by: Frank Nägler <>
Reviewed-by: Frank Nägler <>

History

#1 Updated by Gerrit Code Review 3 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61622

#2 Updated by Tilo Baller 3 months ago

  • Related to Bug #88493: Exception in Indexed Search Administration Modul added

#3 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61622

#4 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61744

#5 Updated by Devid Messner 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#6 Updated by Oliver Hader 3 months ago

  • Due date set to 2018-11-26
  • Start date changed from 2019-09-04 to 2018-11-26
  • Follows Bug #86994: indexed_search doesn't index pages using route enhancers added

#7 Updated by Oliver Hader 3 months ago

  • Due date deleted (2018-11-26)
  • Start date deleted (2018-11-26)

Also available in: Atom PDF