Bug #89084

DB Analyzer Compare Fails with Typo3 9.5.8 and MariaDB 10.3

Added by Lioh Moeller over 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Database API (Doctrine DBAL)
Target version:
-
Start date:
2019-09-05
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
DBAL MariaDB
Complexity:
Is Regression:
Sprint Focus:

Description

We have set up Typo3 according to the specifications listed here: https://get.typo3.org/version/9#system-requirements

As database engine we are using MariaDB 10.3 as listed as supported there.

When we run the DB Analyzer in Maintenance / Analyse Database, we got the following messages:

Typo3 Test Result:
============================================================================================
ALTER TABLE `be_groups` CHANGE `title` `title` VARCHAR(50) DEFAULT '' NOT NULL
Current value: title VARCHAR(50) DEFAULT '''' NOT NULL COLLATE utf8mb4_unicode_ci
...

The test function used for this seems to be:

Typo3 Compare Source: /typo3/sysext/core/ext_tables.sql
/.../
CREATE TABLE be_groups (
        title varchar(50) DEFAULT '' NOT NULL,
/.../

SQL Database Read: SELECT COLUMN_NAME AS Field, COLUMN_TYPE AS Type, IS_NULLABLE AS `Null`, 
                          COLUMN_KEY AS `Key`, COLUMN_DEFAULT AS `Default`, EXTRA AS Extra, 
                          COLUMN_COMMENT AS Comment, CHARACTER_SET_NAME AS CharacterSet, 
                          COLLATION_NAME AS Collation 
                     FROM information_schema.COLUMNS 
                    WHERE TABLE_SCHEMA = 'typo3_tri_hp_eu' 
                      AND TABLE_NAME = 'be_groups' 
                    ORDER BY ORDINAL_POSITION ASC

The actual DB result from a manual query is:

SQL DB Result:
============================================================================================
Field    Type        Null    Key    Default        Extra    Comment    CharacterSet    Collation
title    varchar(50)    NO            ''                            utf8mb4            utf8mb4_unicode_ci

When I manually compare it, the results are actually the same:

        title varchar(50) DEFAULT '' NOT NULL,
        title varchar(50)            ''

But still the Typo3 DB Compare function fails, probably because the test function adds ' ' around the result.

DBAL is the version shipped with Typo3 9.5.8 which is actually 2.8.

#1

Updated by Manuel Selbach about 2 years ago

Since version 9.5.8 of TYPO3 doctrine/dbal should be installed in version 2.9.2.

How did you install TYPO3?
Is there any other dependency that might block installing doctrine/dbal in version 2.9.2?

If version 2.9.2 of doctrine/dbal is installed, may I ask you to check it again and provide some feedback?

I tried to reproduce the error locally with MariaDB 10.3 and doctrine/dbal in version 2.9.2. Everything finished successfully.

#2

Updated by Manuel Selbach about 2 years ago

  • Assignee set to Manuel Selbach
#3

Updated by Riccardo De Contardi almost 2 years ago

  • Status changed from New to Closed
  • Assignee deleted (Manuel Selbach)

There has no feedback since 90 days > Closing this issue.

If you think that this is the wrong decision and have more information about how to reproduce it, please reopen it or open a new issue with a reference to this one.

Thank you.

Also available in: Atom PDF