Bug #89098

Broken nightly tests for core master because of missing test function shouldBeCalledOnce

Added by Frank Naegler 14 days ago. Updated 14 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
Category:
Tests
Target version:
-
Start date:
2019-09-06
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

With #89066 a test was introduce which use shouldBeCalledOnce() which is available since version 1.8.1 but the minimum version of is phpspec/prophecy is 1.7.6

Associated revisions

Revision 46852c29 (diff)
Added by Frank Naegler 14 days ago

[BUGFIX] Fix broken nightlies because of unknown function

The minimum version of phpspec/prophecy is 1.7.6 and does not
contain the method `shouldBeCalledOnce()`.

Resolves: #89098
Related: #89066
Releases: master
Change-Id: Iacfda5c100ec809ea0f7f21ce2e113571b6ae25a
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61633
Tested-by: Andreas Fernandez <>
Tested-by: TYPO3com <>
Tested-by: Anja Leichsenring <>
Reviewed-by: Andreas Fernandez <>
Reviewed-by: Anja Leichsenring <>

History

#1 Updated by Gerrit Code Review 14 days ago

  • Status changed from In Progress to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61633

#2 Updated by Gerrit Code Review 14 days ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61633

#3 Updated by Frank Naegler 14 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF