Bug #89120

Loggers miss the requestId

Added by Helmut Hummel 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-09-09
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Because requestId is now an (optional) constructor argument of LogManager, but LogManager is instantiated by the bootstrap
first without this argument, the requestId remains empty.

The LogManager is indirectly instantiated the first time when error handling is set up and a logger is injected into ErrorHandler


Related issues

Related to TYPO3 Core - Task #84082: A LogRecord should not rely on global state (requestId from Bootstrap) Closed 2018-02-28

Associated revisions

Revision 61e98434 (diff)
Added by Helmut Hummel 7 months ago

[BUGFIX] Ensure LogManager has requestId set

Since LogManager is first used when ErrorHandler is instantiated,
we need to provide a properly set up singleton before
setting up error handling.

Resolves: #89120
Releases: 9.5
Change-Id: I05cb3845472627aae2c0e2949e2fb4a8b74385ea
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61652
Tested-by: Benjamin Franzke <>
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Reviewed-by: Benjamin Franzke <>
Reviewed-by: Benni Mack <>

History

#1 Updated by Helmut Hummel 7 months ago

  • Related to Task #84082: A LogRecord should not rely on global state (requestId from Bootstrap) added

#2 Updated by Gerrit Code Review 7 months ago

  • Status changed from New to Under Review

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61652

#3 Updated by Helmut Hummel 7 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#4 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF