Bug #89151

Module Backend Users: unable to paste copied user

Added by Lidia Demin 3 months ago. Updated 3 months ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-09-11
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Being in the Backend Users module it is possible to copy a user via the context menu. However it is not possible to paste the copied user. Neither there is a paste icon appearing in the list, nor does the "past after" link in the context menu work (it simply happens nothing). See screenshot for better visualization.

Although it is possible to paste the copied user if switching to list module (either by directly clicking it and navigating to proper page or by using the context menu), it is not self-explanatory.

typo3-v9-be-user-module-past-user-bug.png View (70.3 KB) Lidia Demin, 2019-09-11 17:11

Associated revisions

Revision 1c9e2ee4 (diff)
Added by Andreas Fernandez 3 months ago

[BUGFIX] Load language labels in RecordProvider

The generic RecordProvider used for context menus now explicitly loads
the language labels for the modals.

Resolves: #89151
Releases: master, 9.5
Change-Id: If4368f507a0432606298fd5b17b05bf7c665d1d8
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61692
Tested-by: Benjamin Franzke <>
Tested-by: Frank Nägler <>
Tested-by: Anja Leichsenring <>
Tested-by: TYPO3com <>
Reviewed-by: Benjamin Franzke <>
Reviewed-by: Frank Nägler <>
Reviewed-by: Anja Leichsenring <>

Revision 0564b354 (diff)
Added by Andreas Fernandez 3 months ago

[BUGFIX] Load language labels in RecordProvider

The generic RecordProvider used for context menus now explicitly loads
the language labels for the modals.

Resolves: #89151
Releases: master, 9.5
Change-Id: If4368f507a0432606298fd5b17b05bf7c665d1d8
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/61814
Tested-by: TYPO3com <>
Tested-by: Frank Nägler <>
Reviewed-by: Frank Nägler <>

History

#1 Updated by Andreas Fernandez 3 months ago

  • Status changed from New to Accepted

Nothing happens on clicking "paste after" because language labels are missing and the JavaScript explodes:

Uncaught TypeError: Cannot read property 'button.cancel' of undefined
    at jQuery.fn.init.pasteInto (ContextMenuActions.js?bust=1568207119:13)
    at jQuery.fn.init.pasteAfter (ContextMenuActions.js?bust=1568207119:13)
    at HTMLAnchorElement.<anonymous> (ContextMenu.js?bust=1568207119:13)
    at HTMLAnchorElement.dispatch (jquery.js?bust=1568207119:5233)
    at HTMLAnchorElement.elemData.handle (jquery.js?bust=1568207119:5040)

#2 Updated by Gerrit Code Review 3 months ago

  • Status changed from Accepted to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61692

#3 Updated by Gerrit Code Review 3 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61692

#4 Updated by Gerrit Code Review 3 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61692

#5 Updated by Gerrit Code Review 3 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61692

#6 Updated by Gerrit Code Review 3 months ago

Patch set 5 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61692

#7 Updated by Gerrit Code Review 3 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/61814

#8 Updated by Andreas Fernandez 3 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF