Bug #89339

Doktype Shortcut of translated page ignored

Added by Christian Eßl 4 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Frontend
Target version:
-
Start date:
2019-10-03
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Tested in:
  • TYPO3 9.5.9 with a customer project
  • master with introduction package
Setup:
  • Create a site with the languages "Default" and "German"
  • Create a page "Parent page"
  • Create a subpage of that page called "Subpage"
  • Now translate both pages to "German"
  • Change the german version of "Parent page" to doktype "Shortcut". (The original language will stay with "Standard")
  • Set "Shortcut mode" to "First subpage of current page"
Test:
  • Go to the frontend
  • Switch to language "German"
  • Click on the menu link for "Parent page"
Expected behaviour:
  • The page "Subpage" and its contents will be shown
Actual behaviour:
  • The page "Parent page" and its contents will be shown.

Looks like TYPO3 ignores the doktype "Shortcut" of the translated page and sticks with the doktype of the default language.

History

#1 Updated by Christian Eßl 4 months ago

  • Description updated (diff)

#2 Updated by Christian Eßl 4 months ago

  • Description updated (diff)

#3 Updated by Christian Eßl 4 months ago

  • Description updated (diff)

#4 Updated by Riccardo De Contardi 4 months ago

Is this the same issue: #87815 (or at least related)?

#5 Updated by Christian Eßl 3 months ago

Those are not the same.

But I can't reproduce the bug on master anymore. My mistake: I just found out, that we have a custom MenuDataProcessor in use here for building menus, that doesn't take shortcuts for translated pages into account. In the core itself it looks like everything is working correctly.
-> this issue can be closed.

#6 Updated by Riccardo De Contardi 3 months ago

  • Status changed from New to Closed
  • Target version deleted (Candidate for patchlevel)

Hi, @Christian Eßl and thank you for your answer.

I close this issue; if you think that this is the wrong decision or experience the issue again please reopen it or open a new issue with a reference to this one.

Also available in: Atom PDF