Bug #89359

sys_file_reference does not exists in workspace

Added by Romain Tiger about 1 year ago. Updated 6 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Workspaces
Target version:
-
Start date:
2019-10-07
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

We get the error "sys_file_reference:the-uid does not exists" (ajax response) in workspace mode.

We have been able to replicate the issue following these steps :
  1. switch to a live edit
  2. create a news
  3. add a picture
  4. save the news
  5. switch to a workspace
  6. remove the picture
  7. go to filelist and delete the picture

Now if you try to display the changes in workspace mode, you got no changes because of a 500 internal error on the ajax request.

In my debug process, I figured out that entries in the 'sys_refindex' table (linked to the file) are not deleted when deleting the file, which creates the internal error.


Related issues

Related to TYPO3 Core - Bug #67676: Element "sys_file_reference:XXX" does not exist" Closed 2015-06-22

History

#1 Updated by Christian Kuhn about 1 month ago

  • Status changed from New to Needs Feedback

Hey.

I'm unable to reproduce this issue in v10. I tried that with a regular image content element:
Having an image in live attached and dropping the image reference in workspace, still leads to 2 references to the image.
If I then try to delete the file in the file list module, this does not succeed since it says "file not deleted, there are still references".
So I'm unable to recreate you scenario to make the workspace module fail.

Could you re-test your scenario in v10 and see if it is still reproducible for you? If so, what am I doing wrong?

#2 Updated by Christian Kuhn 6 days ago

  • Related to Bug #67676: Element "sys_file_reference:XXX" does not exist" added

#3 Updated by Christian Kuhn 6 days ago

  • Status changed from Needs Feedback to Closed

I'm quite sure this has been fixed with #67676

Also available in: Atom PDF