Bug #89605

Epic #89595: Improve accessibility of backend

Form elements in invisible tabs of contentIframe backend are focusable

Added by Michael Telgkamp 7 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Must have
Assignee:
-
Category:
Backend User Interface
Target version:
-
Start date:
2019-11-07
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
accessibility
Complexity:
Is Regression:
Sprint Focus:

Description

Using the keyboard you can focus form elements in invisible tabs. This should not be possible.

In the screenshot you see the notification checkbox focused while the password tab is active.

FocusedInvisibleCheckbox.png View (35.4 KB) Michael Telgkamp, 2019-11-07 11:26

Associated revisions

Revision 5c453acb (diff)
Added by András Ottó 4 months ago

[BUGFIX] Hide invisible tab-panes to prevent focus hidden form elements

Remove an old hotfix entirely because CKEditor seems to work
without this settings but this caused an accessibility issue for
the backend forms

Resolves: #89605
Releases: master, 9.5
Change-Id: Ie288e6971719aa94da2972f2ea46495e4f0cd728
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62827
Tested-by: TYPO3com <>
Tested-by: Michael Telgkamp <>
Tested-by: Torben Hansen <>
Tested-by: Susanne Moog <>
Reviewed-by: Michael Telgkamp <>
Reviewed-by: Torben Hansen <>
Reviewed-by: Oliver Bartsch <>
Reviewed-by: Susanne Moog <>

Revision 8a15b2d2 (diff)
Added by András Ottó 4 months ago

[BUGFIX] Hide invisible tab-panes to prevent focus hidden form elements

Remove an old hotfix entirely because CKEditor seems to work
without this settings but this caused an accessibility issue for
the backend forms

Resolves: #89605
Releases: master, 9.5
Change-Id: Ie288e6971719aa94da2972f2ea46495e4f0cd728
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63029
Tested-by: TYPO3com <>
Tested-by: Susanne Moog <>
Reviewed-by: Susanne Moog <>

History

#1 Updated by Gerrit Code Review 5 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62827

#2 Updated by Gerrit Code Review 5 months ago

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62827

#3 Updated by Gerrit Code Review 5 months ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62827

#4 Updated by Gerrit Code Review 5 months ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62827

#5 Updated by Gerrit Code Review 4 months ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63029

#6 Updated by András Ottó 4 months ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

#7 Updated by Benni Mack 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF