Bug #89658

RuntimeException Unable to get a property on a non-object when parsing new Symfony ExpressionLanguage expressions

Added by Peter Kraume over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
TypoScript
Target version:
-
Start date:
2019-11-12
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.3
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

My error logs gets flooded with errors like this: "RuntimeException Unable to get a property on a non-object"

/vendor/symfony/expression-language/Node/GetAttrNode.php in Symfony\Component\ExpressionLanguage\Node\GetAttrNode::evaluate at line 73

This happens to Symfony Expression Language expressions in TypoScript.

The expressions that I use are always like this: getTSFE().id == 1

TYPO3: 9.5.11
PHP: 7.3.10


Files

expression.png (165 KB) expression.png Peter Kraume, 2019-11-12 22:00

Related issues

Is duplicate of TYPO3 Core - Bug #87021: Using "getTSFE().beUserLogin == 1" as expression in an TypoScript condition leads to an error in the Symfony Expression LanguageClosed2018-11-28

Actions
#1

Updated by Markus Klein over 1 year ago

  • Is duplicate of Bug #87021: Using "getTSFE().beUserLogin == 1" as expression in an TypoScript condition leads to an error in the Symfony Expression Language added
#2

Updated by Markus Klein over 1 year ago

  • Status changed from New to Closed

Closing as duplicate.

Accessing getTSFE() (in BE context) will be fixed with #87021

Also available in: Atom PDF