Task #89704

Update nikic/php-parser to ~4.3.0

Added by Alexander Schnitzler 20 days ago. Updated 19 days ago.

Status:
Resolved
Priority:
Should have
Category:
-
Target version:
-
Start date:
2019-11-18
Due date:
% Done:

100%

TYPO3 Version:
10
PHP Version:
Tags:
Complexity:
Sprint Focus:

Associated revisions

Revision 669fab81 (diff)
Added by Alexander Schnitzler 19 days ago

[TASK] Update nikic/php-parser to ^4.3

composer require nikic/php-parser:"^4.3"

Bump version as PHP 5 support is not necessary for TYPO3
version 10 and modern packages like rector/rector need
a newer version of nikic/php-parser to work.

Releases: master
Resolves: #89704
Change-Id: I402714959750b5203a6e0117e5ef84b62229441b
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62339
Reviewed-by: Oliver Klee <>
Reviewed-by: Benni Mack <>
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>

History

#1 Updated by Gerrit Code Review 20 days ago

  • Status changed from New to Under Review

Patch set 2 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62339

#2 Updated by Gerrit Code Review 20 days ago

Patch set 3 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62339

#3 Updated by Gerrit Code Review 19 days ago

Patch set 4 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62339

#4 Updated by Anonymous 19 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF