Bug #89779

Editors cannot enable beuser created with taskcenter

Added by Jan Loderhose 11 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-11-26
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

If an editor creates a new backend user with the taskcenter the new user is created "hidden". Thus rendering the new backend user useless. Editing the new be_user in the taskcenter doesn't help. The hidden flag is always set anew on saving.
Since editing rights for be_user datasets cannot be made available to editors, there is no other way than to ask an administrator/integrator to activate newly created be_users.

Currently, we are running on TYPO3 9.5.11.
Our task setup was established in TYPO3 6.2 and worked reliable with 7.6 and 8.7, too. New beusers are created disabled since we updated to TYPO3 9.5 a while back.

Did we miss any changes in the creation of backend users through the taskcenter or is it a bug? Atm it looks like the DataHandler does not accept certain actions if they are triggered by a non-admin. If creating/editing be_users in the taskcenter as an admin everything works as expected.

Steps to reproduce:
  1. create a be_group, grant its members rights top use the taskcenter and assign any editor.
  2. create a task to create be_users and assign it to the be_group.
  3. change into the editors account and create a new enabled be_user.

Related issues

Related to TYPO3 Core - Bug #87536: Editors cannot enable backend users created with sys_action "Create Backend User" Closed 2019-01-24

History

#1 Updated by Michael Sollmann 10 months ago

Can confirm this.

#2 Updated by Riccardo De Contardi 8 months ago

  • Related to Bug #87536: Editors cannot enable backend users created with sys_action "Create Backend User" added

#3 Updated by Riccardo De Contardi 8 months ago

  • Status changed from New to Closed

I close this issue as a duplicate of #87536, please continue the discussion there. I've created a relation between the issues and reported there the comment of your issue to keep track of it.

If you think that this is the wrong decision please reopen it or ping me.

Also available in: Atom PDF