Task #89930

[BUGFIX] Only last postProcContent-hook is applied

Added by Forger Service 4 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
-
Target version:
-
Start date:
2019-12-12
Due date:
% Done:

0%

TYPO3 Version:
8
PHP Version:
Tags:
Complexity:
Sprint Focus:

Description

postProcContent-hooks are used to update page content before it is sent
to the browser, e.g. by processing extra item markers.
When a hook is called, the current page content is passed as parameter
$_params and the modified content is returned by the hook.
Unfortunately the $_params-object is not updated in the loop which
calls all hooks. Each hook is called with the initial page content, and
only the return value of the last hook is returned as the overall
result (i.e. final page content).

This change updates the $_params-object in each iteration, so each hook-
function is called with the updated content of the previous hook. This
ensures that the modifications of all hooks are applied and not only
the modifications of the last hook.

This issue was automatically created from https://github.com/TYPO3/TYPO3.CMS/pull/221


Related issues

Duplicates TYPO3 Core - Bug #89679: postProcContent hooks in felogin override each other Closed 2019-11-14

History

#1 Updated by Gerrit Code Review 4 months ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62608

#2 Updated by Susanne Moog 2 months ago

  • Duplicates Bug #89679: postProcContent hooks in felogin override each other added

#3 Updated by Susanne Moog 2 months ago

  • Status changed from Under Review to Closed

Duplicate of #89679

Also available in: Atom PDF