Bug #90067

NewContentElementController fails to set ID, leads to incorrect PageTS

Added by Mathias Bolt Lesniak 17 days ago. Updated 5 days ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Backend API
Target version:
-
Start date:
2020-01-08
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

I received this PR for the frontend_editing extension. I think it tries to solve a bug in the core.
https://github.com/FriendsOfTYPO3/frontend_editing/pull/388

Because TYPO3 v9 and higher doesn't set the "id" parameter, PageTS isn't generated correctly and settings made in PageTS are not loaded.

History

#1 Updated by Mathias Bolt Lesniak 5 days ago

Can be closed. Resolved thanks to help from Benni Mack.

#2 Updated by Benni Mack 5 days ago

  • Status changed from New to Closed

Closing this one now. One can instantiate the NewContentElementController handing in a custom request (having a GET variable for the page) via init($request) to do this.

See the PR on GitHub.

Also available in: Atom PDF