Bug #90080

Fluid ViewHelper inline f:translate with f:format.raw not working

Added by Christian Holzmann 10 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2020-01-10
Due date:
% Done:

0%

TYPO3 Version:
9
PHP Version:
7.2
Tags:
fluid, viewhelper, inline
Complexity:
Is Regression:
Sprint Focus:

Description

Hello!

The following usage of ViewHelpers should (IMHO) produce the same output:

<f:format.raw><f:translate key="KEY"/></f:format.raw>

{f:translate(key:'KEY')->f:format.raw()}

Currently (TYPO3 9.5.11) it does not.
I tried with a translation string that has ­ in the text.

With the inline Viewhelper usage I get &shy;
with the tags it works, i get ­

Kind regards,
Chris

History

#1 Updated by Georg Ringer 8 months ago

  • Status changed from New to Needs Feedback

this should be solved, at least I can't reproduce that anymore. please retest with latest version

#2 Updated by Riccardo De Contardi 5 months ago

  • Status changed from Needs Feedback to Closed

No feedback since the last 90 days => closing this issue.

If you think that this is the wrong decision or experience the issue again and have more information about how to reproduce your problem, please reopen it or open a new issue with a reference to this one.

Thank you and best regards

Also available in: Atom PDF