Bug #90123

Avoid applying zero prefix for zero in StaticRangeMapper

Added by Oliver Hader over 1 year ago. Updated over 1 year ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Link Handling, Site Handling & Routing
Target version:
-
Start date:
2020-01-15
Due date:
% Done:

100%

Estimated time:
TYPO3 Version:
9
PHP Version:
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Range from '01' to '03' correctly leads to ['01','02','03']. The
prefix mechanism is however applied for a range from '0' to '11'.
This should only happen when explicitly having used '00' to '11'.


Related issues

Related to TYPO3 Core - Bug #87730: Route Enhancers/Aspects: StaticRangeMappers make PersistedAliasMapper be ignoredClosed2019-02-18

Actions
#1

Updated by Gerrit Code Review over 1 year ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62920

#2

Updated by Oliver Hader over 1 year ago

  • Related to Bug #87730: Route Enhancers/Aspects: StaticRangeMappers make PersistedAliasMapper be ignored added
#3

Updated by Gerrit Code Review over 1 year ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/62935

#4

Updated by Oliver Hader over 1 year ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100
#5

Updated by Benni Mack over 1 year ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF