Project

General

Profile

Actions

Bug #90271

closed

TCEFORM Pages - Missing flag when we don't allow default language

Added by Yohann CERDAN over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
FormEngine aka TCEforms
Target version:
-
Start date:
2020-01-31
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
Complexity:
Is Regression:
Sprint Focus:

Description

Hi,

When we edit pages, we have a problem to display the default language flag.

For examples, we have 3 langs :
- 0 / EN
- 1 / FR
- 2 / DE

We have an editor, who can only edit contents in FR & DE.
When he edit the page properties in FR, we see the missing icon instead of the flag of the default language.
If we allow him the EN language (uid=0), everything is alright.

Made some few tests to find a problem in the class : typo3\sysext\backend\Classes\Form\FieldWizard\OtherLanguageContent.php - function render()
We have this line : $html[] = $iconFactory->getIcon($this->data['systemLanguageRows'][0]['flagIconIdentifier'], Icon::SIZE_SMALL)->render();

But, in our case, this is the $this->data['systemLanguageRows'] array :

-1 => array(4 items)
uid => -1 (integer)
title => 'Toutes les langues' (18 chars)
iso => 'DEF' (3 chars)
flagIconIdentifier => 'flags-multiple' (14 chars)
1 => array(4 items)
uid => 1 (integer)
title => 'Fran├žais' (9 chars)
iso => 'fr' (2 chars)
flagIconIdentifier => 'flags-fr' (8 chars)
2 => array(4 items)
uid => 2 (integer)
title => 'Deutsch' (7 chars)
iso => 'de' (2 chars)
flagIconIdentifier => 'flags-de' (8 chars)

So $this->data['systemLanguageRows']0 will return an error.


Related issues 1 (0 open1 closed)

Is duplicate of TYPO3 Core - Bug #88909: FormEngine OtherLanguageContent: fallback to "flags-multiple" icon identifier where no site config is presentClosedJosef Glatz2019-08-03

Actions
Actions #1

Updated by Georg Ringer over 4 years ago

  • Description updated (diff)
Actions #2

Updated by Georg Ringer over 4 years ago

thanks for creating the patch and your detailed report. this has been fixed with #88909. therefore I am closing this issue. however I will also take a look if we shouldn't backport this to 9.5 as well.

Actions #3

Updated by Georg Ringer over 4 years ago

  • Status changed from New to Closed
Actions #4

Updated by Georg Ringer over 4 years ago

  • Is duplicate of Bug #88909: FormEngine OtherLanguageContent: fallback to "flags-multiple" icon identifier where no site config is present added
Actions

Also available in: Atom PDF