Bug #90339

f:link.typolink not working properly, break html code while escape single single quotes

Added by Ghanshyam Bhava 18 days ago. Updated 7 days ago.

Status:
Resolved
Priority:
Should have
Assignee:
-
Category:
Fluid
Target version:
-
Start date:
2020-02-07
Due date:
% Done:

100%

TYPO3 Version:
9
PHP Version:
Tags:
typolink, fluid
Complexity:
medium
Is Regression:
Sprint Focus:

Description

I am using TYPO3 version 9.5.13 currently and customize fluid_style_content and created a lightbox view for the image. Check out fluid syntax below:

<f:link.typolink parameter="{f:uri.image(image: gallery.rows.1.columns.1.media, width:gallery.rows.1.columns.1.dimensions.width,
height: gallery.rows.1.columns.1.dimensions.height)}" 
additionalAttributes="{data-lightbox: 'lightbox{data.uid}',                                  
 data-title: '<div class=\'logo\'>{f:image(src: \'EXT:MyExtension/Resources/Public/Images/logo.png\')}</div><div class=\'lb-content\'>{data.bodytext -> f:format.raw()}</div>'}">Weitere Bilder</f:link.typolink>

I downgraded the TYPO3 version to 9.5.11, in the version its working fine. So, In a nutshell, functionality breaks from TYPO3 9.5.12.

HTML_Broken.png View (135 KB) Ghanshyam Bhava, 2020-02-07 10:25

Associated revisions

Revision c9eecb93 (diff)
Added by Nikita Hovratov 7 days ago

[BUGFIX] Ignore quotes in tag attribute value decoding

This patch: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62227
introduced decoding of attribute values in tags. This was necessary for
email link parameter, but broke html inside attribute tags, because
quotes were left unescaped.

Resolves: #90339
Releases: master, 9.5
Change-Id: I3c336901df6e3ee5eeea46888db11c40986ced56
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63274
Tested-by: TYPO3com <>
Tested-by: Benni Mack <>
Tested-by: Richard Haeser <>
Reviewed-by: Benni Mack <>
Reviewed-by: Richard Haeser <>

Revision f0a9b400 (diff)
Added by Nikita Hovratov 7 days ago

[BUGFIX] Ignore quotes in tag attribute value decoding

This patch: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62227
introduced decoding of attribute values in tags. This was necessary for
email link parameter, but broke html inside attribute tags, because
quotes were left unescaped.

Resolves: #90339
Releases: master, 9.5
Change-Id: I3c336901df6e3ee5eeea46888db11c40986ced56
Reviewed-on: https://review.typo3.org/c/Packages/TYPO3.CMS/+/63293
Tested-by: TYPO3com <>
Tested-by: Richard Haeser <>
Reviewed-by: Richard Haeser <>

History

#1 Updated by Ghanshyam Bhava 18 days ago

  • Description updated (diff)

#2 Updated by Ghanshyam Bhava 18 days ago

#3 Updated by Nikita Hovratov 8 days ago

That patch causes this behaviour since v9.5.12: https://review.typo3.org/c/Packages/TYPO3.CMS/+/62227

#4 Updated by Gerrit Code Review 8 days ago

  • Status changed from New to Under Review

Patch set 1 for branch master of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63274

#5 Updated by Gerrit Code Review 7 days ago

Patch set 1 for branch 9.5 of project Packages/TYPO3.CMS has been pushed to the review server.
It is available at https://review.typo3.org/c/Packages/TYPO3.CMS/+/63293

#6 Updated by Nikita Hovratov 7 days ago

  • Status changed from Under Review to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF