Project

General

Profile

Actions

Bug #90428

closed

missing files on a website result in a crash/error message about missing hash

Added by Daxboeck no-lastname-given about 4 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Should have
Assignee:
-
Category:
Content Rendering
Target version:
Start date:
2020-02-19
Due date:
% Done:

0%

Estimated time:
TYPO3 Version:
9
PHP Version:
7.2
Tags:
hash file_missing
Complexity:
medium
Is Regression:
Yes
Sprint Focus:

Description

Dear TYPO3 developers,

Since 9.5.14 we recognized the following new behaviour of TYPO3:

On a page where a file is missing (e.g. an image file was deleted on the disk), we now get a Crash with a message about missing Hash.
Previously the page did still work and just not display the missing image.

A page should not crash with an error message just because a file is missing. It should only do so in "debug" mode and then give an appropriate error message "file missing".

However there seems to be a hashing mechanism, which does cause a crash, if it tries to hash a missing file.
There I propose that this mechanism is made more error tolerant.

Best regards,

Patrick

Actions #1

Updated by Susanne Moog almost 4 years ago

  • Status changed from New to Needs Feedback

Hey,

just tried to reproduce this issue, I did the following:

- added a text with image element to my site with an image
- deleted the file on the disc
- opened the frontend

--> I get an img tag with a reference to the now deleted image (not rendered) -> no crash

next I tried:
- text with image element, one image, cropped
- deleted the original file and the processed image
- opened the frontend

--> I get an img tag with a reference to the now deleted image (not rendered) -> no crash

next I tried deleting the image via file list -> does not work as there are references to it.

I have no idea on how to reproduce a crash.

Can you please provide:
- Steps how to reproduce this
- The exception / error message (and potentially the stacktrace) or a screenshot of the full error

Actions #2

Updated by Daxboeck no-lastname-given almost 4 years ago

Dear Susanne,

I believe that it might be difficult to reproduce.
Concerning my installation, I used the error log to fix all affected pages.

However the images were missing since a couple of years and so it is possible that the error itself is a combination of upgrade and update.
With 9.5.14 I just started to get the Hash error messages.

So you probably would be more successful, if you installed TYPO3 6LTS, created pages with text + image content, then deleted the image directly on the disk drive (not via filelist/files) and then you would upgrade that system through 7LTS, 8LTS to 9LTS 9.5.13 and then update to 9.5.14 and then you may get the error.

I have also to admit that my main installation is quite complex with over 50 sites, over 30 languages and more than 20'000 active pages and more than 100 domains.

I could give you access to a "demo/development" clone which still has the issue and where I could reproduce it.

For me the priority is low as I fixed all cases of this problem manually.

Thank you very much and best regards,

Patrick Daxboeck

Actions #3

Updated by Christian Kuhn about 2 years ago

  • Status changed from Needs Feedback to Closed

Hey. I hope it's ok to close here: the author outlined a complex scenario to maybe reproduce the issue and said it's also low-prio for him. i think if the problem still exists, we may have a better chance to tackle it with a more straight reproduce in a current core version. let's do that in a fresh issue if that is the case.

Actions

Also available in: Atom PDF